Excel Hilfe für WVERWEIS an einem Beispiel

WVerweis zur besseren Erklärung in einem Text-Beispiel mit Noten-Tabelle.

Die Funktion WVERWEIS sucht als waagerechter Verweis den gesuchten Wert in der angegebenen ZEILE des Suchbereichs.Die Funktion SVERWEIS hingegen, sucht die Funktion senkrecht nach dem Suchwert in der im Index angegebenen SPALTE der Matrix und gibt dann den gewünschten Wert aus. Die Matrix ist eine Tabelle mit Informationen, in der die Daten gesucht werden.

Ein einfaches Beispiel um diese Formel anzuwenden ist eine Notentabelle.In der Zeile A führt man Zelle für Zelle die Punkteverteilung von 0 bis zum Beispiel 100 in einem angemessenen Intervall auf. In der Zeile B, direkt unter die Punkte verteilt man die Noten von 6,0 bis 1,0. Kleine Intervalle bei der Notenvergabe sind wichtig, da die Funktion wenn sie keinen Wert findet, der mit dem Gesuchten genau übereinstimmt, automatisch den nächst Kleineren als Ergebnis anzeigt.

Wenn die Tabelle angelegt ist, legt man sich unter ihr ein Suchfeld an, indem man eine Zelle mit "Punkte" benennt, welche später gesucht werden und eine darunter mit "Note" als Suchkriterium. Neben dem Notenfeld geben wir nun die Formel ein, in genau die Zelle in der das Ergebnis erscheinen soll.Die Funktion ist wie folgt aufgebaut: WVERWEIS(Suchkriterium;Matrix;Zeilenindex;Bereich_Verweis)und kann zu dem oben beschriebenen Beispiel so aussehen:=WVERWEIS(B4;A1:G2;2)Das Feld B4 ist hier das Punktefeld, welches uns als Suchgrundlage dient, A1:G2 ist die Tabelle oder auch Matrix welche nach Punkten aufsteigend sortiert ist und ;2 beschreibt die Zeile in der sich die gesuchte Note befindet. Somit kann B4 (Punkte) beliebig verändert werden und die Formel zeigt jeweils die Note an, welche der (abgerundeten) Punktzahl entspricht.

Der Bereich_Verweis- hier ;2, kann FALSCH sein. In diesem Fall werden nur Ergebnisse geliefert, wenn eine exakte Übereinstimmung gefunden wird. Somit ist die Noten-Funktion wie folgt erweitert: =WVERWEIS(B4;A1:G2;2;FALSCH)In diesem Fall muss die erste Spalte der Tabelle auch nicht sortiert sein. Wird keine genaue Übereinstimmung gefunden, wird als Ergebnis der Fehlerwert "#NV" angezeigt.

  • ÄHNLICHE EINTRÄGE